Signhost Service outage
Resolved
All systems operational
Posted Apr 10, 2017 - 10:34 CEST
Investigating
Generall Connection issues
Posted Apr 10, 2017 - 10:28 CEST