Itsme unavailable
Incident Report for Evidos trust services
Resolved
The technical problem has been resolved. Itsme® is available again.
Posted Sep 28, 2020 - 16:28 CEST
Investigating
Itsme® is currently not available due to a technical problem. The teams of Itsme are doing their utmost best to solve this asap.
Posted Sep 28, 2020 - 16:18 CEST
This incident affected: ⮑ External verifications (itsme).