We are currently experiencing some problems creating transactions.
Incident Report for Evidos trust services
Resolved
This incident has been resolved.
Posted Nov 17, 2020 - 12:59 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 17, 2020 - 12:32 CET
Investigating
We are investigating the issue
Posted Nov 17, 2020 - 12:30 CET
This incident affected: API and Portal.