(Too) strict procedure issue with our data hosting provider firewall.
Incident Report for Signhost
Resolved
This incident has been resolved.
Posted 8 days ago. Feb 08, 2019 - 15:14 CET
Identified
The offending policy rule has been identified and should be updated shortly.
Posted 8 days ago. Feb 08, 2019 - 13:39 CET
Investigating
At the moment we are monitoring an increased amount of blockades, which prevents part our customers from using the portal, and part of the signers to complete the sign request.

We are investigating the issue.
Posted 8 days ago. Feb 08, 2019 - 11:25 CET
This incident affected: UI / View, Portal, and Auth.