Delay when opening singing links
Incident Report for Signhost Verified Signing
Resolved
This incident has been resolved.
Posted Mar 19, 2024 - 08:47 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2024 - 17:27 CET
Investigating
We are currently experiencing an issue where some users experience a delay when opening a singing link. We are investigating the issue.

If you experience this, please try opening the link again in a private/incognito window in your browser.
Posted Mar 18, 2024 - 16:51 CET
This incident affected: UI / View.