Itsme verification outage
Incident Report for Signhost Verified Signing
Resolved
Itsme has implemented a fix for this issue. All Itsme services are operational.
Posted Nov 04, 2019 - 15:06 CET
Update
We are continuing to work on a fix for this issue.
Posted Nov 04, 2019 - 14:48 CET
Identified
There is currently an outage with the Itsme verification method
Posted Nov 04, 2019 - 14:37 CET
This incident affected: ⮑ External verifications (itsme Identification).