ID proof unavailable

Incident Report for Signhost Verified Signing

Resolved

This incident has been resolved.
Posted Apr 11, 2023 - 14:07 CEST

Update

We are continuing to work on a fix for this issue.
Posted Apr 11, 2023 - 13:51 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 11, 2023 - 13:45 CEST
This incident affected: ID Proof and Webforms.