Subscriptions can't be upgraded or extended
Incident Report for Evidos trust services
Resolved
The incident has been resolved.
Our invoicing system stopped working on Friday last week, and queues started to form with accounts to be created and invoices to be send out. For some reason these were not generated and sent out in real time anymore. To investigate the problem, we had to do a deep dive into our internal invoicing services. During the course of this week we deployed multiple logging fixes to get to the core of the problem, and yesterday evening we rolled out a solution which fixed the aforementioned problems.
Since tonight invoices are generated again in real time and it is fully possible to create and upgrade selfservice accounts again.
Posted Dec 22, 2022 - 09:31 CET
Update
We are continuing to work on a fix for this issue.
Posted Dec 21, 2022 - 10:06 CET
Identified
It is not possible to upgrade your free GO account to a paid subscription.
Extending your subscription is also not possible
Posted Dec 15, 2022 - 11:14 CET
This incident affected: Account and billing service.