Verification method itsme is currently experiencing issues
Incident Report for Signhost Verified Signing
Resolved
This incident has been resolved.
Posted Aug 26, 2024 - 10:23 CEST
Monitoring
A solution has been rolled out by itsme and the service has been restored.

We are monitoring the situation.
Posted Aug 26, 2024 - 10:11 CEST
Investigating
Itsme is experiencing a technical problem, impacting 25% or more of itsme transactions.
Itsme is currently investigating the issue and working on a solution to resolve the issue as fast as possible.
Posted Aug 26, 2024 - 09:55 CEST
This incident affected: ⮑ External verifications (itsme sign (qualified signature), itsme Identification).