Sender domain e-mails are experiencing a delay
Incident Report for Evidos trust services
Resolved
This incident has been resolved.
Posted Aug 09, 2022 - 12:15 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 09, 2022 - 12:12 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 09, 2022 - 12:10 CEST
Investigating
If you have the option sending e-mails from your own domain -- the e-mails are currently experiencing a delay.

We are very sorry for the inconvenience.
Posted Aug 09, 2022 - 12:00 CEST
This incident affected: External services (Mail service).