Error in creating account
Incident Report for Signhost Verified Signing
Resolved
This incident has been resolved.
Posted Jun 03, 2021 - 13:17 CEST
Monitoring
A fix has been implemented and we are monitoring the results
Posted Jun 03, 2021 - 11:52 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 03, 2021 - 11:22 CEST
Investigating
We're currently investigating an issue where account requests on our platform result in an error. Please bear with us while we try to resolve this as soon as possible.
Posted Jun 03, 2021 - 10:53 CEST