ID Proof and Webforms incident
Incident Report for Evidos trust services
Resolved
This incident has been resolved.
Posted Oct 13, 2021 - 11:10 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 13, 2021 - 11:05 CEST
Update
Our partner is continuing to investigate the incident.
Posted Oct 13, 2021 - 10:42 CEST
Investigating
Our partner MyCubes has a network related issue. They are currently investigating the incident and we'll keep you informed through this page.
Posted Oct 13, 2021 - 09:44 CEST
This incident affected: ID Proof and Webforms.