Issue with creating transactions
Incident Report for Signhost Verified Signing
Postmortem

What happened?

On Monday April 22 at 11:59 our core Signhost application encountered a database connection disturbance. This connectivity issue resulted in an immediate downtime of our signing services.
The database cluster was healthy, although the response times of the query's took longer than expected.

What did we do?

After having noticed the issue occurring we directly tried to analyze what the root cause may be and we've immediately contacted our hosting party to also check their logging for any issues.
Simultaneously we partially put some of our servers in maintenance mode. Once we found out this didn’t work we decided to put all servers in maintenance mode while continuing investigating the slow response times to the database.

After about an half hour we've gradually start bringing the servers online and after an hour- and half we're fully operational again.

What was the cause of the downtime?

Our hosting was performing routine software maintenance on some storage disks. While this should normally not impact the availability of our service, unfortunately it did.

Posted Apr 24, 2024 - 13:24 CEST

Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 16:00 CEST
Update
All servers are back up and the system is performing as expected. We keep monitoring the situation.
Posted Apr 22, 2024 - 13:59 CEST
Update
We are continuing to monitor for any further issues.
Posted Apr 22, 2024 - 13:50 CEST
Update
Our API is operational but we are holding off bringing our portal online again until we see the api performing stable for a while. We expect to restore the portal as soon as possible.
Posted Apr 22, 2024 - 13:44 CEST
Monitoring
The service is operational again, however might still be slow in places. We are monitoring the situation.
Posted Apr 22, 2024 - 13:32 CEST
Identified
We identified the cause of the problems, being issues connecting to our database cluster.
Connection to our database was restored, and we are bringin our services back online as soon as possible.
We are in close contact with our hosting provider to restore full functionality.
Posted Apr 22, 2024 - 13:04 CEST
Investigating
We are currently experiencing issues with creating transactions.
We are investigating the issue.
Posted Apr 22, 2024 - 12:09 CEST
This incident affected: API and Portal.