New accounts are having issues activating
Incident Report for Signhost Verified Signing
Resolved
This incident has been resolved.
Posted Nov 27, 2020 - 16:38 CET
Monitoring
Accounts can be verified again. We are monitoring the implemented fix.
Posted Nov 27, 2020 - 14:56 CET
Investigating
We are investigating an issue where new Evidos web portal accounts cannot verify their email with the verification link.

Existing accounts are not experiencing issues.
Posted Nov 26, 2020 - 11:46 CET
This incident affected: Portal.