Issue with iDEAL and iDIN transactions

Incident Report for Signhost Verified Signing

Resolved

This incident has been resolved.
Posted Jul 16, 2024 - 22:21 CEST

Monitoring

We see transactions being completed succesfully again the last few minutes. It looks like the banks restored functionality, we are monitoring the situation.
Posted Jul 16, 2024 - 20:32 CEST

Update

iDIN and iDeal management consoles from our partner banks are not reachable, this looks like a broader issue with the bank payment and identity schemes.
Posted Jul 16, 2024 - 20:11 CEST

Investigating

We're currently experiencing issues with successfully signing of iDEAL and/or iDIN transactions. This has our fullest attention and we'll update this page as soon we know more.
Posted Jul 16, 2024 - 19:29 CEST
This incident affected: ⮑ External verifications (iDIN, iDEAL).