ItsMe Qualified Electronic Signature is unavailable at the moment
Resolved
Itsme has solved their issue and is operational again
Posted Feb 17, 2023 - 15:31 CET
Identified
We have identified that verification via ItsMe Qualified Electronic Signature is not working.

Our partner is investigating this issue.

ItsMe Identification does still work.
Posted Feb 15, 2023 - 17:36 CET
This incident affected: ⮑ External verifications (itsme sign (qualified signature)).