Signhost QES - Outage

Incident Report for Signhost Verified Signing

Resolved

This incident has been resolved.
Posted Apr 22, 2026 - 07:48 CEST

Identified

Our provider is experiencing problems. Signhost QES cannot be used. The issue has been identified, the resolution is being handled.
Posted Apr 21, 2026 - 17:35 CEST
This incident affected: Portal and ⮑ External verifications (Signhost QES).