DigiD login might results in an error.
Incident Report for Evidos trust services
Resolved
This incident has been resolved.
Posted Jun 17, 2022 - 16:51 CEST
Investigating
We are currently investigating this issue with our partner.
Posted Jun 17, 2022 - 14:38 CEST
This incident affected: ⮑ External verifications (DigiD).