Activating itsme app not possible on Android for NL users.
Incident Report for Evidos trust services
Resolved
Itsme has reactivated their app activation flow for new NL users on Android.
Posted Jun 30, 2022 - 09:35 CEST
Update
Our partner itsme had their app reapproved by Google. They expect creation of new itsme accounts for Dutch users on Android to be working again on monday.
Posted Jun 24, 2022 - 15:08 CEST
Identified
This incident is only relevant if you use our signing method itsme.

Our partner itsme has an issue where the itsme app cannot be activated for users from the Netherlands on Android. Existing users, IOS users, and users in other countries such as Belgium encounter no issues.

Itsme is working hard to get their app reapproved, when we learn more from them we will update this page.
Posted Jun 23, 2022 - 15:14 CEST
This incident affected: ⮑ External verifications (itsme sign (qualified signature), itsme Identification).