Issues with ID Proof web form

Incident Report for Signhost Verified Signing

Resolved

This incident has been resolved.
Posted Nov 06, 2025 - 10:53 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 06, 2025 - 10:32 CET

Investigating

We are currently experiencing an issue with our ID Proof web forms where not all text and options are displaying correctly
Our provider is investigating the cause.
Posted Nov 06, 2025 - 10:20 CET
This incident affected: ID Proof.