Degraded Performance – CSC Qualified Verification

Incident Report for Signhost Verified Signing

Resolved

This incident has been resolved.
Posted Mar 17, 2026 - 10:59 CET

Monitoring

We see degraded performance with the CSC Qualified verification method. Some signers may encounter issues completing the signing process.

A fix has been implemented, and we are now monitoring the system to ensure full recovery. We will update this status once we confirm that the issue has been fully resolved.
Posted Mar 17, 2026 - 10:34 CET
This incident affected: ⮑ External verifications (itsme sign (qualified signature), ZealiD Qualified, Signhost QES).