Issues with itsme Identification (AES) verification method.

Incident Report for Signhost Verified Signing

Resolved

This incident has been resolved.
Posted Jul 23, 2026 - 16:18 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 23, 2026 - 15:57 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 23, 2026 - 15:41 CEST

Investigating

We are currently experiencing an issue affecting the itsme Identification (AES) verification method within Signhost. As a result, transactions that use this verification method cannot be completed at this time. We are investigating this issue.
Posted Jul 23, 2026 - 14:49 CEST
This incident affected: ⮑ External verifications (itsme Identification).