Branding option temporarily not visible in the portal
Incident Report for Evidos trust services
Resolved
This incident has been resolved.
Posted Dec 09, 2019 - 14:35 CET
Identified
We are currently working on a fix
Posted Dec 09, 2019 - 11:04 CET
This incident affected: Portal.