ID Proof and Webforms incident
Incident Report for Evidos trust services
Resolved
This incident has been resolved.
Posted Nov 18, 2021 - 18:10 CET
Investigating
Our partner MyCubes has an outage. They are currently investigating the incident and we'll keep you informed through this page.
Posted Nov 18, 2021 - 17:35 CET
This incident affected: ID Proof and Webforms.