SMS delivery delays
Incident Report for Evidos trust services
Resolved
This incident has been resolved.
Posted May 27, 2021 - 17:20 CEST
Monitoring
A fix has been implemented by Messagebird, we see messages arriving again.
Posted May 27, 2021 - 17:16 CEST
Investigating
Our partner Messagebird is investigating an issue with SMS delivery.
Posted May 27, 2021 - 17:11 CEST
This incident affected: ⮑ External verifications (Phonenumber / SMS).