We are investigating downtime for our ID Proof and forms service. Other services are operational.
Incident Report for Signhost Verified Signing
Resolved
This incident has been resolved.
Posted Jun 18, 2021 - 13:58 CEST
Investigating
We are currently investigating this issue.
Posted Jun 18, 2021 - 13:42 CEST
This incident affected: ID Proof and Webforms.