A fix has been implemented, we are monitoring the results.
Posted May 28, 2026 - 16:13 CEST
Investigating
We are continuing to investigate the issue with the verification method itsme Identification (AES). Signers may still experience issues completing the signing process. The itsme Sign (QES) method via CSC Qualified verification remains unaffected.
We will share further updates as soon as more information becomes available.
Posted May 28, 2026 - 15:31 CEST
Identified
The issue has been identified. We will proceed to implement a fix for this issue.
Posted May 28, 2026 - 12:19 CEST
Update
We are continuing to investigate this issue.
Posted May 28, 2026 - 10:30 CEST
Investigating
We are currently experiencing issues with the verification method itsme Identification (AES). As a result, signers may be unable to complete the signing process.
The itsme Sign (QES) method via CSC Qualified verification is not affected.
Our team is actively investigating the issue.
Posted May 28, 2026 - 09:06 CEST
This incident affected: ⮑ External verifications (itsme Identification).