Issue with creating transactions
Incident Report for Signhost Verified Signing
Postmortem

What happened?

On Monday March 4 at 9:45 CEST network issues occurred at our cloud provider as a result transaction creation and signing was not possible.

At 13:27 our cloud provider migrated our database instances which initially resulted in yet another short period of outage. Within a few minutes this migration resolved our issues, creating transactions and signing was possible again.

What did we do?

As soon as we noticed the issue, we started putting parts of our platform in maintenance. We quickly discovered though that our whole platform was suffering from this issue, so we decided to put the whole platform in maintenance mode to prevent the message queues filling up and to have the database catching up again. The moment the database caught up we enabled our services one by one, starting with the API and moving on from there. Around 13:55 we were fully operational again.

We also re-acknowledged with our cloud provider that they should not do any migrations without our explicit permission.

What will we do better?

  • Improve our communication with our cloud provider. We need to verify our agreements with them periodically to ensure these agreements are being followed up correctly.
  • We’re constantly improving our database setup, i.e. hunting down expensive queries, setting up indexes, cleaning up unused data, etc. We will continue doing so.
  • We were already in the process of improving the design of the database setup as a whole and this issue gave us a better insight in what parts need to be improved.
  • Further improve monitoring of our current database setup.
Posted Mar 07, 2024 - 13:18 CET

Resolved
The incident has been resolved. We are working on getting all information and evaluating, a post mortem will be posted later when this process is done.
Posted Mar 04, 2024 - 16:03 CET
Update
We set the portal live some minutes ago and it seems it is holding as well. We keep monitoring the situation but all services seem operational again.
Posted Mar 04, 2024 - 13:55 CET
Update
Our api and document viewer services are back operational again, transactions can be created. Portal is still down while we monitor current load
Posted Mar 04, 2024 - 12:17 CET
Update
Unfortunately the database is severely slowing down again and transaction creation is not consistently possible. We are in contact with our hosting provider and focussing our efforts on solving this problem. Please bear with us as we treat this issue with utmost priority.
Posted Mar 04, 2024 - 11:26 CET
Monitoring
We put the system back live 10 minutes ago and the db is holding up, we are monitoring the situation but transactions can be created again.
Posted Mar 04, 2024 - 11:16 CET
Update
Because of delays in created transactions being propagated to our database, new transactions cannot be created to make sure no additional load is added to already full queues. We are focussing on getting database delays down and enable transaction creation as soon as possible. We will keep you posted through this channel
Posted Mar 04, 2024 - 10:27 CET
Update
We are continuing to investigate this issue.
Posted Mar 04, 2024 - 10:17 CET
Investigating
We are currently experiencing issues with creating transactions.
We are investigating the issue.
Posted Mar 04, 2024 - 09:56 CET
This incident affected: API and Portal.