Itsme advanced connection error
Incident Report for Evidos trust services
Resolved
This incident has been resolved.
Posted Dec 06, 2019 - 12:20 CET
Investigating
It's currently not possible to sign with itsme advanced. We are investigating this issue.
Posted Dec 05, 2019 - 11:32 CET
This incident affected: ⮑ External verifications (itsme).