Verification method itsme is currently experiencing issues

Incident Report for Signhost Verified Signing

Resolved

This incident has been resolved.
Posted Dec 10, 2025 - 10:50 CET

Monitoring

itsme has implemented a solution, and the service has been restored. The situation is being closely monitored to ensure stability.
Posted Dec 10, 2025 - 10:37 CET

Update

itsme is still investigating the issue, and systems are beginning to recover. Full service has not yet been restored.

We will share updates as soon as more information is available. Thank you for your patience.
Posted Dec 10, 2025 - 10:33 CET

Investigating

Itsme is currently experiencing a technical issue affecting 25% or more of their transactions since 9:40 AM CET. Their technical teams are actively investigating the problem and working to resolve it as quickly as possible.

We understand the inconvenience this may cause and will continue to monitor the situation closely. Updates will be provided as soon as more information becomes available.
Posted Dec 10, 2025 - 10:10 CET
This incident affected: ⮑ External verifications (itsme sign (qualified signature), itsme Identification).