Email Delivery Delays

Incident Report for Signhost Verified Signing

Identified

We have identified that the delays affecting email notifications sent by Signhost are related to a broader Microsoft 365 Exchange Online incident.

At this time, the Signhost platform remains fully operational, and document processing, signing, and transaction handling are not affected. The impact is limited to email notifications being delivered later than usual. Recipients may experience delays in receiving notifications.

We are continuing to monitor the situation closely together with our email service provider. We will provide the next update on Monday morning.
Posted Sep 04, 2026 - 16:28 CEST

Update

We are investigating delays affecting email notifications sent by Signhost. The Signhost platform remains fully operational and document processing is not impacted. The issue is currently limited to email delivery, which may result in notifications reaching recipients later than usual. We are working with our email service provider to resolve the issue as quickly as possible
Posted Sep 04, 2026 - 14:49 CEST

Investigating

We are currently experiencing an issue that is causing delays in the delivery of emails sent from our platform. As a result, emails may take longer than expected to reach recipients.
Posted Sep 04, 2026 - 12:12 CEST
This incident affects: External services (Mail service).