Itsme services down
Incident Report for Signhost Verified Signing
Resolved
This incident has been resolved by itsme.
Posted Feb 28, 2020 - 13:30 CET
Identified
DOWN - Major Outage Notification - All Environments (PRD-E2E-UAT)



itsme is currently facing a major outage impacting all itsme® Services.

All services are down, and with all environments impacted (PRD/E2E/UAT).

Current Actions:

The cause of the breakdown is still being investigated and itsme is taking all necessary measures to remediate.

We will keep you informed as soon as we have more information available.
Posted Feb 28, 2020 - 12:28 CET
This incident affected: ⮑ External verifications (itsme Identification).