All services unavailable due to major outage
Incident Report for Evidos trust services
Resolved
This incident has been resolved.
Posted Jun 22, 2020 - 13:44 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 22, 2020 - 13:12 CEST
Investigating
We are currently investigating the issue
Posted Jun 22, 2020 - 12:27 CEST
This incident affected: API, UI / View, and Portal.