Degraded e-mail delivery performance
Incident Report for Signhost Verified Signing
Resolved
This incident has been resolved.
Posted Feb 08, 2024 - 12:07 CET
Monitoring
Our mailprovider has worked with Microsoft to ensure email delivery. See their message below:

Sparkpost:
"Beginning last week we made a change to add a URL to the list-unsubscribe header to be compliant with new rule “one-click” unsubscribe requirements from Gmail and Yahoo. After this update, some customers started reporting an increase in [new] junk foldering of messages destined to Office 365 addresses - it appears they were flagged by Microsoft’s Defender filtering framework. We worked with Microsoft who made changes to address this issue. In addition, some customers reported a large increase in opens and clicks on Monday and Tuesday of this week that we believe were caused by some action by Microsoft - likely a reclassification or redelivery routine."

We expect mails to be delivered in the inbox instead of being flagged as junk in the new junk folder since monday, and are in contact with our customers to ensure that indeed email now arrives.
Posted Feb 08, 2024 - 09:26 CET
Identified
We are currently experiencing an issue where some users receive less or no automatic Signhost e-mails.

This is down to recent changes in the spam filters of big mail providers (Microsoft, Gmail, Yahoo) which results in stricter monitoring of mails to prevent possible spam. Unfortunately, because of that change, our e-mail is now also sometimes mistakenly marked as spam or phishing and filtered out of recipients' mailboxes. Therefore, there may be no or fewer mails that appear to have been received from us.

We are aware of this and are in discussions with the party sending our mails to resolve this. In the meantime, we would like to advise you to place our mail domain (noreply@signhost.com) or your configured sending domain on your allowlist and register it as a safe sender. If possible, also configure your spam filter to accept the URL https://eu.spgo.io/ as safe.

Should you be waiting for signed documents and/or the transaction receipt you can retrieve them from the Signhost web portal.
Posted Feb 06, 2024 - 10:57 CET
This incident affected: External services (Mail service).