DigiD outage

Incident Report for Signhost Verified Signing

Resolved

The issues with DigiD have been resolved by Logius.
Posted Mar 23, 2026 - 15:01 CET

Monitoring

The issues with logging into DigiD have been solved by Logius.
Posted Mar 23, 2026 - 14:38 CET

Investigating

There are currently issues with logging into DigiD. Logius is investigating the issue, we will communicate any updates.
Posted Mar 23, 2026 - 13:29 CET
This incident affected: ⮑ External verifications (DigiD).