Signhost QES - Outage

Incident Report for Signhost Verified Signing

Resolved

Signhost QES is operational again.
Posted May 05, 2026 - 10:42 CEST

Monitoring

The issue has been fixed. We are monitoring the situation.
Posted May 05, 2026 - 10:11 CEST

Identified

Our provider is experiencing issues. The Signhost QES verification cannot be completed for now.
Posted May 05, 2026 - 09:07 CEST
This incident affected: ⮑ External verifications (Signhost QES).