Issues with CSC Qualified verification method

Incident Report for Signhost Verified Signing

Resolved

This incident has been resolved.
Posted Feb 14, 2025 - 15:57 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 14, 2025 - 15:48 CET

Investigating

We are experiencing issues with the CSC Qualified verification method for Qualified Electronic Signatures.
Signers get stuck in the process of signing and are not able to finish the signing process. We are investigating the issue.
Posted Feb 14, 2025 - 15:10 CET
This incident affected: ⮑ External verifications (itsme sign (qualified signature), ZealiD Qualified).