ID Proof Signhost app issues

Incident Report for Signhost Verified Signing

Resolved

A new app update was deployed and approved by IOS/Android this morning around 9:00. Downloading the latests app version restores ID Proof functionality for people that identify.
Posted Mar 04, 2025 - 12:14 CET

Update

A new build is created and pushed to IOS/Android. We are awaiting approval from the OS vendors and will update this space when any news comes in.
Posted Mar 03, 2025 - 10:31 CET

Identified

We are investigating an issue with ID proof. It seems our last fix solved all issues on the web end, but for customers that are using the Signhost mobile app for ID proofing, there still remains an issue connecting to the IDV backend when trying to scan a document or make a selfie. It looks like we need to update our mobile IOS and Android apps to get this right, and are working with the app dev team and IOS/Android to get a new build fast tracked. We will keep you updated through this channel. NFC and webbrowser based IDV are not impacted.
Posted Feb 28, 2025 - 16:38 CET
This incident affected: ID Proof and Signhost App.