Itsme sign is experiencing connectivity issues
Incident Report for Signhost Verified Signing
Resolved
itsme has resolved the technical problems on their end. Qualified Signing with itsme should work again.
Posted Jan 20, 2021 - 14:10 CET
Investigating
itsme is experiencing a technical issue affecting itsme® Signing.
The service is currently degraded.
They are investigating the cause with the highest priority.

We will update this incident when itsme provides further information on their research and repair.

The Evidos signing service itself and other external verifications are operational.
Posted Jan 20, 2021 - 11:38 CET
This incident affected: ⮑ External verifications (itsme sign (qualified signature)).