Issue creating new users
Incident Report for Signhost Verified Signing
Resolved
This incident has been resolved.
Posted Oct 22, 2019 - 10:00 CEST
Identified
The issue has been identified and we are currently working on a fix
Posted Oct 21, 2019 - 14:57 CEST
Investigating
We are currently experiencing a malfunction in the creation of new users / accounts and the password reset process.
Posted Oct 21, 2019 - 14:27 CEST
This incident affected: Portal.