Itsme connectivity problems
Incident Report for Signhost Verified Signing
Resolved
The incident is currently resolved, and all services are working again.

The itsme® team continues to closely monitor and follow up of the performance of the system. We will provide an update on the root cause when we have additional information.

We appreciate your patience and understanding. For any additional questions about this incident, pleasecontact operations@itsme.be.
Posted Dec 07, 2021 - 14:23 CET
Update
Itsme® is still actively working on the resolution of the incident. As soon as we have further information we will update you through this channel.
Posted Dec 07, 2021 - 12:33 CET
Update
We are continuing to investigate this issue.
Posted Dec 07, 2021 - 09:33 CET
Investigating
Since 8:40AM (approx.) you may experience some slowness or connectivity problems with itsme® services.

They are investigating the cause and will provide an update as soon as they have more information available.

We apologize for the inconvenience.
Posted Dec 07, 2021 - 09:33 CET
This incident affected: ⮑ External verifications (itsme sign (qualified signature), itsme Identification).