Technical incident - itsme® Signing
Incident Report for Evidos trust services
Resolved
This incident has been resolved.
Posted Jun 15, 2021 - 15:27 CEST
Monitoring
The Sign service is back up and running. Belgian Mobile ID keeps on monitoring the services for the coming hours.
Posted Jun 15, 2021 - 13:22 CEST
Investigating
Belgian Mobile ID is currently experiencing a technical issue affecting itsme® Signing.
They are investigating the cause and we will provide an update as soon as we have more detail.
Posted Jun 15, 2021 - 12:20 CEST
This incident affected: ⮑ External verifications (itsme sign (qualified signature)).