Itsme sign is experiencing connectivity issues
Incident Report for Evidos trust services
Resolved
Itsme has resolved this issue.
Posted Aug 13, 2020 - 16:08 CEST
Investigating
Itsme is investigating the problem. We will update this page if they notify us of a solution or relevant progress.
If you are not using verification method itsme sign you can disregards this message.
Posted Aug 13, 2020 - 13:49 CEST
This incident affected: ⮑ External verifications (itsme).