Verification method itsme is currently experiencing issues

Incident Report for Signhost Verified Signing

Resolved

This incident has been resolved.
Posted Apr 20, 2026 - 10:00 CEST

Monitoring

Itsme has identified the root cause of the issue. Their systems are currently recovering, and their technical teams are closely monitoring stability to ensure a full and safe resolution.

We will continue to monitor the situation and share further updates as soon as they become available.
Posted Apr 20, 2026 - 09:57 CEST

Investigating

Itsme is currently experiencing a technical issue affecting 25% or more of their transactions since 9:25 AM CET. Their technical teams are actively investigating the problem and working to resolve it as quickly as possible.

We understand the inconvenience this may cause and will continue to monitor the situation closely. Updates will be provided as soon as more information becomes available.
Posted Apr 20, 2026 - 09:52 CEST
This incident affected: ⮑ External verifications (itsme sign (qualified signature), itsme Identification).