Verification method itsme is currently experiencing issues
Incident Report for Signhost Verified Signing
Resolved
Monitoring shows that the Itsme systems are stable since their solution has been rolled out and this incident is therefore closed.
Posted Jun 19, 2024 - 09:42 CEST
Monitoring
A solution has been rolled out and the service has been restored.
Itsme are monitoring the situation closely.
Posted Jun 19, 2024 - 09:22 CEST
Investigating
Itsme is experiencing a technical problem, impacting 25% or more of itsme transactions.
Itsme is currently investigating the issue. See their statuspage for more information: https://itsme.statuspage.io/
Posted Jun 19, 2024 - 09:19 CEST
This incident affected: ⮑ External verifications (itsme sign (qualified signature)).