Issue creating transactions
Incident Report for Signhost Verified Signing
Postmortem

What happened?

On Thursday September 26 starting around 10:25 CEST users were unable to create transactions caused by an issue with a database node.  

What did we do?

After having noticed the issue occurring, we directly tried to analyze what the root cause may be, and we have immediately contacted our hosting party to also check their logging for any issues.

Simultaneously we put our platform in maintenance mode to prevent overloading while continuing investigating the issue.

Our hosting provider discovered a problem with one of the database servers. We moved the first database to a different server, which helped improve things. After bringing our platform back online we noticed the delay occurring again and decided to immediately put the platform in maintenance mode again.

We decided to also migrate the second database node. However, when we tried to move the second database, our hosting party ran into some issues. As a solution, we switched the commits database to the first server. After making this change, the platform stabilized.

We gradually start bringing the servers online and after about half an hour we were fully operational again.

What was the cause of the downtime?

Our hosting party identified high traffic on the server where our database node was running, which led to performance problems. To fix this, we tried moving our database servers to different hardware. Moving the first server helped improve the situation somewhat, but we encountered problems when trying to move the second server. Our cloud hosting provider found an issue with this second server, which prevented the migration. This caused the delay and the downtime of the platform.

We will work to gain better insights into the status of our database servers, including monitoring their performance and load more effectively. This will help us detect issues earlier and take corrective action faster.

We will keep in close contact with our hosting partner to prevent this from happening again.

Posted Oct 01, 2024 - 09:28 CEST

Resolved
The incident has been resolved. We are working on getting all information and evaluating, a post mortem will be posted later when this process is done.
Posted Sep 26, 2024 - 15:03 CEST
Monitoring
We have identified an issue with our hosting provider and have implemented a fix. We are monitoring the results closely.
Posted Sep 26, 2024 - 13:23 CEST
Update
Our API is operational but we are holding off bringing our portal online again. We continue to investigate the issue.
Posted Sep 26, 2024 - 13:00 CEST
Investigating
The implemented fix did not solve the issue. Please bear with us as we treat this issue with utmost priority.
Posted Sep 26, 2024 - 12:09 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 26, 2024 - 12:01 CEST
Update
Unfortunately, we have not yet been able to identify the problem. We are in close contact with our providers and continue to investigate this issue with the highest priority.
Posted Sep 26, 2024 - 11:45 CEST
Update
We have put the complete platform in maintenance while we are investigating the issue. Our services are unavailable for the time being.
Posted Sep 26, 2024 - 11:01 CEST
Investigating
We are currently experiencing issues when creating transactions. We are investigating the issue.
Posted Sep 26, 2024 - 10:35 CEST
This incident affected: API and Portal.