Issues with logging in to Signhost web portal

Incident Report for Signhost Verified Signing

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 11:09 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 23, 2026 - 10:38 CET

Investigating

Customers are experiencing issues with logging in to the Signhost web portal. After filling in log in credentials an error message is received: "Invalid credentials"

We are investigating the issue.
Posted Jan 23, 2026 - 10:21 CET
This incident affected: Portal and Auth and login service.