Delay in upgrading or extending subscriptions
Incident Report for Signhost Verified Signing
Resolved
This incident has been resolved.
Posted Mar 16, 2023 - 19:24 CET
Update
We are continuing to work on a fix for this issue.
Posted Mar 16, 2023 - 17:56 CET
Identified
We are currently experiencing issues with changing subscriptions.

There is a delay when you upgrade your free GO account to a paid subscription. Extending your subscription is also delayed. Your upgrades and changes will be processed later today.
Posted Mar 16, 2023 - 15:21 CET
This incident affected: Account and billing service.