Verification method iDEAL is currently not working
Resolved
This incident has been resolved.
Posted Apr 25, 2023 - 16:26 CEST
Monitoring
There was an issue with our iDEAL supplier which is now resolved. We'll keep monitoring the iDEAL service.
Posted Apr 25, 2023 - 16:21 CEST
Investigating
We are investigating the issue.
Posted Apr 25, 2023 - 15:33 CEST
This incident affected: ⮑ External verifications (iDEAL).