Itsme® Services unavailable
Incident Report for Signhost Verified Signing
Resolved
This incident has been resolved
Posted Oct 21, 2020 - 14:27 CEST
Investigating
Itsme®is currently not available due to a technical problem. The Itsme team is doing their utmost best to solve this asap. We will keep you posted and apologize for the inconvenience.
Posted Oct 21, 2020 - 13:48 CEST
This incident affected: ⮑ External verifications (itsme Identification).